Добавление состояния согласования из 1С: Документооборот

Публикация № 1656577 11.05.22

Управленческий учет - Документооборот и делопроизводство

Документооборот Состояние согласования

Добавляем статус согласования из подключенной базы 1С Документооборот в типовые и нетиповые конфигурации с использованием библиотеки интеграции с 1С: Документооборотом. Статусы добавляются в формы списка и формы объектов.

Добавим статус согласования из подключенной базы 1С: Документооборот:

1. Создадим регистр сведений для хранения состояний и быстрого чтения из него

СостоянияСогласованияОбъектовДО измерение ОбъектСогласования, реквизит Состояние

2. Добавить код в ИнтеграцияС1СДокументооборотПереопределяемый.ПриИзмененииСостоянияСогласования

	ТипПредмета = ТипЗнч(ПредметСогласования);
	
	Если РегистрыСведений.СостоянияСогласованияОбъектовДО.ВозможноСохранениеСогласования(ТипПредмета) Тогда
		
		РегистрыСведений.СостоянияСогласованияОбъектовДО.СохранитьСостояниеОбъекта(ПредметСогласования, Состояние);
		
		Возврат;
		
	КонецЕсли;	

3. Добавить код в модуль менеджера регистра СостоянияСогласованияОбъектовДО

Процедура СохранитьСостояниеОбъекта(ПредметСогласования, Состояние) Экспорт

	УстановитьПривилегированныйРежим(Истина);
	
	Набор = РегистрыСведений.СостоянияСогласованияОбъектовДО.СоздатьНаборЗаписей();
	Набор.Отбор.ОбъектСогласования.Установить(ПредметСогласования);
	
	Запись = Набор.Добавить();
	Запись.ОбъектСогласования = ПредметСогласования;
	Запись.Состояние = Состояние;
	
	Набор.Записать();	
	
КонецПроцедуры

Функция ПолучитьСостояниеСогласования(ПредметСогласования) Экспорт
	
	УстановитьПривилегированныйРежим(Истина);	
		
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	СостоянияСогласованияОбъектовДО.Состояние КАК Состояние
		|ИЗ
		|	РегистрСведений.СостоянияСогласованияОбъектовДО КАК СостоянияСогласованияОбъектовДО
		|ГДЕ
		|	СостоянияСогласованияОбъектовДО.ОбъектСогласования = &ОбъектСогласования";
	
	Запрос.УстановитьПараметр("ОбъектСогласования", ПредметСогласования);
	
	РезультатЗапроса = Запрос.Выполнить();
	
	Если РезультатЗапроса.Пустой() Тогда
		
		Возврат Неопределено;
		
	КонецЕсли;                   
		
	СостояниеСогласования = РезультатЗапроса.Выгрузить()[0].Состояние;
	
	Возврат СостояниеСогласования;	
	
КонецФункции	
	
Функция ВозможноСохранениеСогласования(ТипПредмета) Экспорт
		
	ДоступныеТипы = Новый Массив;

	ДоступныеТипы.Добавить(Тип("ДокументСсылка._ДемоРеализацияТоваров"));
	
	Если ДоступныеТипы.Найти(ТипПредмета) = Неопределено Тогда
		Возврат Ложь;
	Иначе 
		Возврат Истина;
	КонецЕсли;	

КонецФункции

4. Изменим динамический список объекта по добавлению колонки состояние (Пример):

ИЗ
	Документ._ДемоРеализацияТоваров КАК Документ_ДемоРеализацияТоваров
		{ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.НаличиеФайлов КАК НаличиеФайлов
		ПО (Документ_ДемоРеализацияТоваров.Ссылка = НаличиеФайлов.ОбъектСФайлами)}
		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.СостоянияСогласованияОбъектовДО КАК СостоянияСогласованияОбъектовДО
		ПО (Документ_ДемоРеализацияТоваров.Ссылка = СостоянияСогласованияОбъектовДО.ОбъектСогласования)

5. Добавим модуль ОбнСост_СостоянияСервер с текстом 

Процедура ДобавитьПолеСтатуса(ЭтаФорма, 
	РодительскийЭлемент = Неопределено, 
	ЭлементПередКоторым = Неопределено) Экспорт
     
    Если Не ЗначениеЗаполнено(ЭтаФорма.Объект.Ссылка) Тогда
    	Возврат;
	КонецЕсли;	
	
	ДобавляемыеРеквизиты = Новый Массив;
	
	ТипРеквизита = Новый ОписаниеТипов("ПеречислениеСсылка.СостоянияСогласованияВДокументообороте");
	
	РеквизитФормы = Новый РеквизитФормы(
		"СостояниеСогласования",  
		ТипРеквизита,     
		"",               					  	
		"Состояние согласования");
						  							 
	ДобавляемыеРеквизиты.Добавить(РеквизитФормы);
	
	ЭтаФорма.ИзменитьРеквизиты(ДобавляемыеРеквизиты);
	
	ЭтаФорма.СостояниеСогласования = РегистрыСведений.СостоянияСогласованияОбъектовДО.ПолучитьСостояниеСогласования(ЭтаФорма.Объект.Ссылка);

	Если ЭлементПередКоторым = Неопределено Тогда
		Если РодительскийЭлемент = Неопределено Тогда
			ПолеВвода = ЭтаФорма.Элементы.Добавить("ФормаСостояниеСогласования", Тип("ПолеФормы"), ЭтаФорма);
		Иначе 
			ПолеВвода = ЭтаФорма.Элементы.Добавить("ФормаСостояниеСогласования", Тип("ПолеФормы"), РодительскийЭлемент);		
		КонецЕсли;	
	Иначе 
		Если РодительскийЭлемент = Неопределено Тогда
			ПолеВвода = ЭтаФорма.Элементы.Вставить("ФормаСостояниеСогласования", Тип("ПолеФормы"), ЭтаФорма, ЭлементПередКоторым);
		Иначе 
			ПолеВвода = ЭтаФорма.Элементы.Вставить("ФормаСостояниеСогласования", Тип("ПолеФормы"), РодительскийЭлемент, ЭлементПередКоторым);		
		КонецЕсли;	
	КонецЕсли;
		
	ПолеВвода.Вид = ВидПоляФормы.ПолеНадписи;
	ПолеВвода.ПутьКДанным = "СостояниеСогласования";	
	
КонецПроцедуры

Процедура ДобавлениеКолонкиСтатуса(Элементы, ЭлементПередКоторым) Экспорт
	
	Элемент = Элементы.Вставить("СтатусСогласования", Тип("ПолеФормы"), Элементы.Список, ЭлементПередКоторым);
	Элемент.ПутьКДанным = "Список.СтатусСогласования";
	Элемент.Заголовок = "Статус согласования";

КонецПроцедуры

и для отображения статуса в формах объектов и формах списков добавим процедуру ДобавитьПолеСтатуса в ПриСозданииНаСервере формы объекта, и ДобавлениеКолонкиСтатуса в ПриСозданииНаСервере формы списка объекта.

Тестирование проводилось на библиотеке интеграции с ДО 1.1.18.6.

Скачать файлы

Наименование Файл Версия Размер
Добавление состояния согласования из 1С Документооборот:

.cfe 37,73Kb
0
.cfe 37,73Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Хранение файлов в томах на диске (для УПП 1.3) Промо

Адаптация типовых решений v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    73091    15    wowik    32    

Автозаполнение шаблонов файлов MXL в "1С:Документообороте"

Документооборот и делопроизводство Адаптация типовых решений v8 ДО Абонемент ($m)

Добавление возможности создавать автозаполняемые шаблоны файлов в формате MXL в 1С:Документооборот и сохранением заполненного файлы в формате PDF (таблицы, результаты запроса реквизиты...)

1 стартмани

05.05.2022    707    1    JIEX@    0    

Отображение проблем синхронизации с Документооборотом 2.1

Документооборот и делопроизводство v8 ДО УУ Абонемент ($m)

Внешний отчет для Документооборот 2.1, основанный на анализе регистра сведений Сведения о сообщениях обмена с интегрированными системами. Можно использовать для сигнализации о проблемах остановки обмена.

1 стартмани

02.01.2022    1973    3    ardn    0    

Программное создание и расчет документов начисления зарплаты в конфигурации ЗУП 3.1 и ERP (по подразделениям)

Зарплата Приемы и методы разработки Адаптация типовых решений v8 v8::СПР ERP2 ЗУП3.x БУ Абонемент ($m)

Краткое описание типового механизма расчета зарплаты в конфигурации ЗУП 3.1 и ERP и описание разработанной обработки по программному расчету документов зарплаты в разрезе подразделений. Т.к. формирование документов происходит полностью программно, с минимумов параметров, его можно брать за основу для расчета документов по своим условиям, вплоть до создания по расписанию при необходимости.

10 стартмани

27.12.2021    3013    4    maraty    37    

Приемная руководителя, редакция 1.1 Промо

Документооборот и делопроизводство v8 Абонемент ($m)

Приемная руководителя, редакция 1.1. Конфигурация на управляемых формах (интерфейс - Такси) с открытым кодом, создана для секретарей.

1500 руб.

19.05.2015    32269    22    10    

Инструменты разработчика для работы с ЭДО СБИС ExtSdk2

Оптовая торговля Документооборот и делопроизводство v8 1cv8.cf Россия Абонемент ($m)

Несколько обработок, которые помогут разработчикам в автоматизации рабочих мест бухгалтеров и менеджеров продаж.

1 стартмани

25.12.2021    2300    9    bobylev1980    4    

БСП 3.1.5 Форма отчета. Быстрый вызов редактирования варианта

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

В последних релизах современных конфигураций, основанных на БСП версии 3.1.5, спрятали кнопку настройки варианта в дебри вложенных форм. Вернём всё как было, и даже лучше.

1 стартмани

20.12.2021    2613    1    the1    0    

Доработка документа для формирования проводок в регламентированном учете ERP

Адаптация типовых решений v8 ERP2 УТ11 БУ Абонемент ($m)

Статья о том, как включить разработанный документ в подсистему формирования проводок в конфигурации ERP

1 стартмани

17.12.2021    3909    4    maraty    6    

Создание внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11) Промо

Адаптация типовых решений Универсальные функции v8 УТ11 Россия Абонемент ($m)

Создание внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11)

1 стартмани

28.03.2013    160536    547    Stradivari    31    

Работа с API Диадок

Документооборот и делопроизводство WEB v8 ДО Абонемент ($m)

Обработка написана для конфигурации Документооборот, затрагивает самые основные методы работы с api Диадок.

5 стартмани

17.12.2021    2015    14    diar01    0    

Устранение проблемы с правами доступа. Документооборот КОРП 2.1

Документооборот и делопроизводство Роли и права v8 ДО Абонемент ($m)

Обработка позволяет открыть доступ для пользователей в конфигурации 1С: Документооборот КОРП 2.1, связанных с отсутствием необходимых записей в регистрах сведений СоставСубъектовПравДоступа и ПользователиВКонтейнерах. Проблема выражается в отсутствии доступа к папкам внутренних документов и непосредственно внутренним документам (см.рисунок).

1 стартмани

01.11.2021    2961    12    baturo    0    

Распознавание текста с использованием OCR Tesseract

Документооборот и делопроизводство v8 ДО Россия Абонемент ($m)

В 1С:Документооборот полнотекстовый поиск по содержимому отсканированных документов возможен, но не так хорош, как бы хотелось. Всё дело в качестве распознавания сканов. Поднимаем процесс распознавания на новую высоту с использованием Xpdf и OCR Tesseract.

5 стартмани

17.10.2021    3277    10    soulner    2    

Управление пользователями в документообороте

Документооборот и делопроизводство Роли и права v8 ДО Россия Абонемент ($m)

Обработка "Управление пользователями в документообороте" позволяет создавать новых пользователей и обновлять права у текущих пользователей. Возможно назначать права группе пользователей и пакетно создавать пользователей с одинаковыми правами. Облегчает рутинную работу при регулярной работе с правами пользователей.

1 стартмани

13.10.2021    3057    13    Smikle    0    

Преобразование doc/docx в PDF для 1С: Документооборот 8 КОРП, ПРОФ, ДГУ через обработчик бизнес-событий

Документооборот и делопроизводство v8 ДО Абонемент ($m)

Обработчик после регистрации нужного вида документа выполняет конвертацию файлов, прикрепленных к внутреннему документу формата doc/docx, в формат PDF и добавляет эти файлы к документу. Не требует изменений в конфигурации.

1 стартмани

05.10.2021    3457    2    vashkostya    1    

Где баланс между производительностью и возможностями программы ? Исправление автоподбора контрагента в УНФ

Рефакторинг и качество кода HighLoad оптимизация Адаптация типовых решений v8 УНФ Россия УУ Абонемент ($m)

Как и у многих ко мне стали поступать обращения от менеджеров о медленной работе 1с (эта ваша один с не дает нормально работать), и чтоб быть объективным, и не основываться на человеческом, субъективном восприятии решил вооружиться цифрами, а именно произвести анализ медленных запросов, и проблема была найдена, где я ее не ожидал.

1 стартмани

27.08.2021    3193    0    con-men    0    

[Расширение] Несколько касс ККМ в РМК для Розницы 2.3

Розничная торговля ККМ Рабочее место Адаптация типовых решений v8 Розница Абонемент ($m)

Расширение добавляет возможность добавлять и работать с несколькими кассами ККМ при продаже через РМК с одного рабочего места

1 стартмани

27.08.2021    3528    28    Nonik    39    

Формирование XML документа (УПД, счет, накладная, СФ и прочее)

Документооборот и делопроизводство Файловые протоколы обмена (TXT, XML, DBF), FTP v8 БП3.0 УТ11 Россия Абонемент ($m)

С помощью этого кода для документов базы формируется XML-файл, который можно отправить через ЭДО СБИС, Диадок и пр. Поддерживается все форматы, которые поддерживает библиотека БЭД.

1 стартмани

24.08.2021    3604    63    blackhorse1976    7    

Учет медосмотров, прививок, и приемов медицинских специалистов

Адаптация типовых решений Кадровый учет v8 ЗУП3.x Здравоохранение, медицина, стоматология Россия Абонемент ($m)

Расширение для ЗУП 3.1, предназначенное для ввода данных медперсоналом по медобследованиям сотрудников организации.

1 стартмани

23.08.2021    3144    18    user767823    6    

Прослеживаемость товара в Диадок (РНПТ). Подключаемый модуль для в УПП 1.3, УТ 10.3

Документооборот и делопроизводство Оптовая торговля v8 УТ10 УПП1 БУ Абонемент ($m)

С июля 2021 года введена прослеживаемости товаров с передачей данных через ЭДО. На данный момент в модуле Диадок (5.42.10) не реализовано заполнение РНПТ, и предлагаемый подключаемый модуль решает эту проблему.

1 стартмани

21.07.2021    4674    35    itmind    6    

Доработка Диадок для 1С. Заполнение графы 5а в УПД (с 01.07.2021). Подключаемый модуль

Документооборот и делопроизводство Оптовая торговля v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

С 1 июля 2021 года действует новая форма УПД, такое изменение принято постановлением №534 от 02.04.2021 г. Правительством Российской Федерации. В форме УПД в данной редакции появилась графа 5а. Мне так и не удалось разобраться - обязательна она к заполнению или нет - в типовой форме в 1С:Бухгалтерия она заполняется, а в Диадок - нет. И было бы пофиг, но некоторые наши клиенты отказались принимать УПД с прочерком в строке 5а. Служба поддержки Диадок сообщила, что заполнение - не является обязательным, доработка - платная, тикет - закрыт :) Поэтому здесь Вы можете скачать Подключаемый модуль для Диадок, который заполняет графу 5а - Документы основания.

1 стартмани

06.07.2021    13922    122    AlxPop    37    

Розница 2.2, 2.3 выбор продавца из справочника Физ. лица перед входом в РМК с возможностью выбора кто будет отображаться в Чеке

Кассовые операции Розничная торговля Адаптация типовых решений v8 Розница Абонемент ($m)

Розница 2.2, 2.3 выбор продавца из справочника Физ. лица перед входом в РМК с возможностью выбора кто будет отображаться в Чеке

1 стартмани

22.06.2021    4065    10    andrey7617    0    

Если после обновления Розницы на версию 2.3.9.22 или более позднюю не определяются марки и некорректно работает сканер штрихкода

Розничная торговля Сканер штрих-кода Адаптация типовых решений v8 Розница Россия Абонемент ($m)

Если после обновления Розницы на релиз 2.3.9.22 или более позднюю. не работает сканер штрихкода версии 10.1.1.1, во вложении - драйвер сканера штрихкода версии 9.0.8.10 и расширение для тех у кого не устанавливается драйвер.

1 стартмани

21.06.2021    11574    169    санясоку    35    

Подсистема "Пользовательские автоподстановки" для 1С: Документооборот 2.1

Документооборот и делопроизводство Анализ и проектирование ИТ-систем v8 ДО Россия УУ Абонемент ($m)

Подсистема позволяет описать собственные алгоритмы автоподстановок исполнителей задач бизнес-процессов. Механизмы подсистемы может использовать любой компетентный пользователь/программист.

1 стартмани

12.05.2021    4741    12    Lok`Tar    13    

Печать и подпись на любых печатных формах 1С (УФ)

Документооборот и делопроизводство WEB v8 v8::УФ УНФ ERP2 БП3.0 УТ11 ЗУП3.x Россия Абонемент ($m)

Обработка для выгрузки любых печатных форм (УТ 11, БП 3.0, УНФ 1.6, ERP) в сервис Sigs.ME для установки на них печати и подписей.

1 стартмани

12.05.2021    4376    1    1psspam    1    

Адресная книга для 1С:Документооборот

Документооборот и делопроизводство v8 ДО Абонемент ($m)

Реализация через http-сервис публикации адресной книги для документооборота.

1 стартмани

27.04.2021    6706    3    SaschaG    7    

Визуализация электронной подписи на документе Adobe PDF с указанием положения

Документооборот и делопроизводство v8 ДО Россия Абонемент ($m)

Делать визуализацию по ГОСТ Р 7.0.97-2016 исходящего документа в формате MS Word мы уже умеем. А если пришел входящий документ в виде картинки или в формате Adobe PDF подписанный ЭЦП, что будем делать? Итак, набив руку на предыдущих работах, готов замахнуться на визуализацию ЭП на документах Adobe PDF и графических файлах.

5 стартмани

26.04.2021    6916    25    soulner    13    

Цифровая подпись. Документооборот КОРП 2.1

Документооборот и делопроизводство v8 ДО Россия Абонемент ($m)

Вставка виртуальной цифровой подписи (грифа утверждения) в автозаполняемые шаблоны word для Документооборот КОРП 2.1. Генерация картинки подписи происходит на сервере с помощью утилиты ImageMagick. Поддерживаемые форматы doc. Заполнение происходит на стороне клиента. Формат docx не поддерживается, т.к. он заполняется на сервере! При желании можно дописать.

5 стартмани

24.02.2021    5062    6    andrew.ab    0    

Помощник Документооборота - реестр задач для 1С:Документооборот

Документооборот и делопроизводство v8 ДО Россия УУ Абонемент ($m)

Помощник Документооборота - реестр задач - обработка для 1С:Документооборот, удобный инструмент для работы с задачами.

1 стартмани

17.02.2021    4454    21    a_l_e_xj    0    

Быстрый просмотр документов PDF и картинок в 1С:Документооборот 2.1

Документооборот и делопроизводство v8 v8::Бизнес-процессы ДО Россия УУ Абонемент ($m)

Когда на нашем предприятии стали подключать руководство к процессам в 1С:Документооборот, появилось вполне логичное требование реализовать быстрый просмотр вложений к документам и задачам. Данное расширение отображает документы PDF и картинки на формах входящих, внутренних, исходящих документов, а также в формах задач на согласование и исполнения и на форме Задачи мне.

2 стартмани

02.02.2021    5826    47    timm00    14    

Рукописная подпись PDF документа в 1С:Документооборот через смартфон/планшет

Документооборот и делопроизводство v8 ДО Абонемент ($m)

Расширение для 1С:Документооборот для наложения рукописной подписи в PDF файле. Расширение позволяет накладывать разное количество подписей пользователей в одном документе. Подписание происходит в Android приложении. Вы можете интегрировать подписание документов в свое приложение. Данное расширение как один из вариантов применения использования подписи. Открытое API для интеграции с любыми 1С конфигурациями и приложениями.

1 стартмани

28.11.2020    7240    12    perevalsky    14    

Учет состояний оригиналов первичных документов

Документооборот и делопроизводство v8 УПП1 Россия БУ УУ Абонемент ($m)

Совсем недавно фирма 1С анонсировала в новой версии 1С:ERP 2.5 подсистему учета состояний оригиналов в первичных документах. Представляю вашему вниманию аналогичную подсистему для 1С:УПП 1.3.

10 стартмани

16.11.2020    6748    14    E_Babaylova    11    

Вставка штампа в файлы PDF

Документооборот и делопроизводство v8 ДО УУ Абонемент ($m)

Как неправильно регистрировать входящие документы? Надо распечатать сопроводительное письмо, зарегистрировать документ в программе, на бумажном носителе поставить штамп, вписать номер и дату и заново отсканировать документ в карточку входящего письма. А как правильно?

1 стартмани

11.11.2020    12956    72    soulner    12